Marketingwebsites X-Guard.nl en BHV-Knop.nl verminderd bereikbaar

Minor incident Ondersteunende systemen X-Guard Website
2025-11-18 01:12 -11 · 3 hours, 6 minutes

Updates

Resolved

The problems with Cloudflare have been resolved. Both X-Guard.nl and BHV-Knop.nl are accessible again. Thank you very much for your patience.

November 18, 2025 · 04:17 -11
Issue

Due to a global outage at Cloudflare, our marketing websites (x-guard.nl and BHV-Knop.nl) are currently experiencing reduced accessibility.

If you are looking for information and the website unexpectedly does not work, you can refresh the page to try again.

More information can be found on Cloudflare Status.

This has no impact on our service delivery. For that reason, no interim updates about this incident will be provided unless the situation changes. Our apologies for the inconvenience.

November 18, 2025 · 01:12 -11

← Back